Liquidated - Fixed Borrow open position <-settle fails

Hey devs,
I can’t settle the amount that was in an open (not allocated) fixed lending position.

I deposited USDC and lended SOL with leverage.
As SOL price increased my collateral sunk.
But I should be able to claim the SOL in the lending position or?

I can’t repay/close open positions.

I deposited USDC to reduce it now to 0,89.
I hope SOL price doesn’t liquidate me one more time.

Programm Log
#1 Compute Budget instruction
> Program returned success
#2 Compute Budget instruction
> Program returned success
#3 Unknown program instruction
> Program log: Instruction: AdapterInvoke
> Program log: account is being liquidated
> Program log: AnchorError occurred. Error Code: Liquidating. Error Number: 141032. Error Message: the account is being liquidated.
> Program JPMRGNgRk3w2pzBM1RLNBnpGxQYsFQ3yXKpuk4tTXVZ  consumed 7358 of 400000 compute units
> Program returned error: custom program error: 0x226e8

I topped up USDC again and was able to settle and all fine now.

hi @nevi-me can you please take a look? Thank you :heart:


problem persists. i would very like to close the position / settle the funds

hey @ivan was this on the current app or

On the current app but in the meantime it has worked.


Glad it’s worked out! Appreciate the update